List:Replication« Previous MessageNext Message »
From:Database System Date:September 17 2008 7:52pm
View as plain text  

I have question need to consult you. Hope you use similar OS system. I use MySQL on
windows few years and it works fine. Now I'm starting MySQL on RedHat Linux. I installed
RPM packege. After installation, the data files & error files are under:
the mysql executable is under
/etc/init.d/  I can start the server from here
mysqld_safe is under
there was no my.cnf generated, I had to create one and put it in /etc/

what value should I put for basedir =  in my.cnf
I added datadir = /data/mysql/data and it worked fine. The server access database in the
directory I setup in my.cnf.

But after I added "log_bin = /data/mysql/log/binlog" in my.cnf, 
the log files are generated under /data/mysql/data/ (same dir with database files) and the
log file name start with mysql-bin which is not what I designed start with 'binlog'
I also tried "log_bin = /data/mysql/log" it did help anything.

I checked the mysql account owns all dir's from /data/ and down. 

Do you know why I set datadir is working and binary log directory doesn't work?

Thank you,

mysql Replication is too slowTimo8 Sep
  • RE: mysql Replication is too slowRick James8 Sep
    • Re: mysql Replication is too slowMarcus Bointon8 Sep
      • RE: mysql Replication is too slowRick James8 Sep
        • ConsultingDatabase System17 Sep
          • RE: ConsultingRick James17 Sep
            • RE: ConsultingDatabase System17 Sep
              • Re: ConsultingMarcus Bointon17 Sep