List:MySQL++« Previous MessageNext Message »
From:Regis Grison Date:October 13 2010 4:11pm
Subject:weird chars instead of table name
View as plain text  

I'm using libmysql++-dev 3.0.0 and mysql-server 5.1.30 on ubuntu 9.04 (I 
can't go to newer version because of a compatibility problem with a 
closed-source software).

I got a really weird problem and I can't find anything on google or on 
the mysql++ website.

I have a Cluster table with only 2 fields: actorId and cluster (both 
varchar). I know a varchar is not a good ID, it's not my code but I have 
to work with it.

The Cluster class is defined here:
sql_create_2(Cluster, 2, 0, std::string, actorId, std::string, cluster)

Then, the call is here:
Cluster data(id,*i);

id is a std::string
i is an iterator, *i returns a std::string
query is a classic mysqlpp::Query

When I run the code, it complains like that :
Error: Invalid utf8 character string: (followed by unprintable chars)

I tried every trick with utf8 and mysql but in fact, I believe it is not 
an utf8 problem because when I print the query, I got:
INSERT INTO ??? (actorId,cluster) VALUES ('azerty','CGP\\FN_Clink.cgp')
where ??? are some unprintable chars (the same as above but change from 
a time to another)

Looks like the table name is not properly set, it should get random data 
and think it is utf8.

I tried to call query.reset() with no success.

I must admit I don't know where to look or what to try now so any tip 
will be appreciated.

Thanks in advance.

Régis (rg)
weird chars instead of table nameRegis Grison13 Oct
  • Re: weird chars instead of table nameAdrian Cornish13 Oct
    • Re: weird chars instead of table nameRegis Grison14 Oct
  • Re: weird chars instead of table nameWarren Young13 Oct
    • Re: weird chars instead of table name (SOLVED)Regis Grison14 Oct