List:MySQL++« Previous MessageNext Message »
From:DazedNConfused71 Date:June 1 2009 11:36am
Subject:Mysql++ client no longer connects but mysql does
View as plain text  

I recently upgraded my mysql version on my gentoo HTPC (uses mythtv) and 
I can no longer access the mysql database from my laptop using a client 
application I wrote with mysql++.  Previously it had been working for 
about a year and now it doesn't.  Interestingly mysql can connect to the 
HTPC database from my laptop.  I am getting the following error with my 

terminate called after throwing an instance of 'mysqlpp::ConnectionFailed'
  what():  Lost connection to MySQL server at 'reading initial 
communication packet', system error: 111

The version of mysqld:

mysqld --version
mysqld  Ver 5.0.70-log for pc-linux-gnu on x86_64 (Gentoo Linux 

I tried upgrading to the latest mysql++ (available in portage) and it is 
still the same problem.  The version is now 2.3.2.

Does anyone have any ideas where I should start looking?


Mysql++ client no longer connects but mysql doesDazedNConfused711 Jun
  • Re: Mysql++ client no longer connects but mysql doesWarren Young1 Jun