List:MySQL++« Previous MessageNext Message »
From:Matt Dargavel Date:September 26 2006 3:05pm
Subject:RE: Install issue on SLES-10
View as plain text  
As a suggestion, try running 'ldconfig' as root and then give it another go.
Ldconfig looks in each of the directories specified in /etc/
(/usr/local/lib should be in there) for shared system libraries and sets
them up ready for use.

-----Original Message-----
From: Gary Anderson [mailto:ganderson@stripped] 
Sent: 26 September 2006 15:29
To: plusplus@stripped
Subject: Re: Install issue on SLES-10

Sorry for the lack of information.  I had actually run the full make, then
make install.  When I tried to run make install again, the response was that
nothing needed to be done, as expected.  The library was actually installed
in /usr/local/lib.  Apparently it did not get on some type of configuration
list for the dynamic library loader.  That is the issue I am trying to

Your suggestion of the LD_LIBRARY_PATH worked temporarily, but I need to
make that configuration permanent on the system.  Do you have any

Warren Young wrote:

> Gary Anderson wrote:
>> when I try to run the examples, I get the error that 
>> cannot be found.
> You probably haven't installed the library yet.  The examples and the 
> library are in separate subdirectories, and Linux's dynamic library 
> loader doesn't know where to find it.  Linux will only look in a few 
> very specific places for the library, and ../lib is not one of them.  
> :)
> If you want to test the library before you formally install it, use a 
> command like this:
> $ LD_LIBRARY_PATH=../lib ./simple1 localhost someuser hispassword
> That clues the dynamic loader that ../lib should also be searched for 
> libraries.
> Otherwise, just install the library, and the examples should run 
> without any jiggery-pokery.

Install issue on SLES-10Gary Anderson25 Sep
  • Re: Install issue on SLES-10Warren Young26 Sep
    • Re: Install issue on SLES-10Gary Anderson26 Sep
      • RE: Install issue on SLES-10Matt Dargavel26 Sep
        • Re: Install issue on SLES-10Gary Anderson26 Sep
      • Re: Install issue on SLES-10Warren Young27 Sep