List:MySQL++« Previous MessageNext Message »
From:Chad Dombrova Date:January 18 2006 5:39pm
Subject:Re: problems compiling on osx
View as plain text  
i tried again on my home machine running osx 10.4

i installed only fink packages - all mysql 4.1 - and i compiled with 

when i ran the compiled examples i got only one dyld error this time:


i then reconfigure and recompiled msql++ with gcc4.0 and everything 
worked fine -- no errors when running the examples.  i know that 
mysql++ is supposed to compile with gcc3.3 so does anyone have any idea 
how to get rid of this pure virtual error with gcc3.3?


On Jan 17, 2006, at 4:34 PM, Warren Young wrote:

> Chad Dombrova wrote:
>>  dyld: resetdb Undefined symbols:
>>  __ZNKSt11logic_error4whatEv
>>  __ZNSoD0Ev
>>  __ZNSoD1Ev
>>  __ZNSs20_S_empty_rep_storageE
>>  __ZNSs4_Rep11_S_max_sizeE
>>  __ZNSs4_Rep11_S_terminalE
>>  __ZNSt24__default_alloc_templateILb1ELi0EE12_S_force_newE
>>  __ZNSt24__default_alloc_templateILb1ELi0EE12_S_free_listE
>>  __ZNSt24__default_alloc_templateILb1ELi0EE22_S_node_allocator_lockE
> None of this is due to MySQL++ or the MySQL C API, directly.  This is 
> all Standard C and C++ library type stuff.  I think you have too many 
> pieces from too many places floating around and getting in each 
> others' ways.  Use all Fink, or all of this eSuite thing, or all stuff 
> from MySQL AB.  Rebuild things from source as much as possible.
> -- 
> MySQL++ Mailing List
> For list archives:
> To unsubscribe:    

problems compiling on osxChad Dombrova18 Jan
  • Re: problems compiling on osxWarren Young18 Jan
    • Re: problems compiling on osxChad Dombrova18 Jan