List:MySQL++« Previous MessageNext Message »
From:Warren Young Date:August 15 2005 4:25pm
Subject:Re: how to fetch a row?
View as plain text  
ZeeGeek wrote:
> I've tried to fetch a row from a table using mysqlpp::Query::use(const char 
> *str) method, but all I got when I printed out row["item"] were all the 
> same, a single letter t. 

Study the simple2 and usequery examples in the v2.0 distribution.

If that isn't enlightening, distill your problem to a small piece of 
code that works against the sample database, and post that.

> then I tried to print the mysqlpp::ResUse out and 
> it was always 1. 

That's normal.  You're just printing the value of ResUse::operator 
bool() here.  If you want it to print the contents of the result set, 
I'm open to patches for that.  For ideas of how to go about it, and some 
idea of the proper scope of this change, see the svn version of the 

how to fetch a row?ZeeGeek15 Aug
  • Re: how to fetch a row?Warren Young15 Aug
Re: how to fetch a row?Warren Young16 Aug
  • Re: how to fetch a row?ZeeGeek17 Aug