List:MySQL++« Previous MessageNext Message »
From:chandra shekar Date:April 15 2005 4:16am
Subject:Not able to install the rpm.
View as plain text  
Dear Friends,
	I am not able to install the rpm file
(mysql++-1.7.30-1.rh9.i386.rpm).I ran the below
command to install the rpm :

"rpm --install /PATH/mysql++-1.7.30-1.rh9.i386.rpm "

It threw the error :" Failed dependecies : 
MySQL - Shared is needed by mysql++-1.7.30-1"

Before running the above command I installed
mysql++-1.7.30.tar.gz as below:
After gunziping and untaring the above file I ran the
below commands:
./configure --includedir=/usr/local/include/mysql

First it gave error: could not find the mysql include
dir in /usr/local/myslq/include/mysql ,
/usr/local/include/mysql, /usr/include/mysql. 

Then I manually created " usr/local/include/mysql "
copied all the *.h files from 
"/usr/local/myslq/include ".  Then again stared
configuring as below :

./configure --includedir=/usr/local/include/mysql
make install

This time I was lucky and SUCCEEDED, but when I tried
to install the rpm file it is giving error as
I mentioned above. 

I also tried running a simple  program that connects
to Mysql but got the error as " mysql_init"
unidentified". I have included "mysql.h" and while
compiling I used the command 
" gcc -I/usr/local/include/mysql prog.c " but for no

Please help me out :o|


Do you Yahoo!? 
Yahoo! Small Business - Try our new resources site!
Not able to install the rpm.chandra shekar15 Apr
  • Re: Not able to install the rpm.Warren Young15 Apr
RE: Not able to install the rpm.Ash Christopher15 Apr