List:General Discussion« Previous MessageNext Message »
From:Michael Widenius Date:August 8 1999 2:31pm
Subject:mysql-3.22.22-unknown-openbsd2.5-i386 binary won't install
View as plain text  
>>>>> "piou" == piou  <piou@stripped> writes:

>> Description:
piou> When I run mysql_install_db, it gives this output:

piou> =====
piou> Creating db table
piou> Creating host table
piou> Creating user table
piou> Creating func table
piou> Creating tables_priv table
piou> Creating columns_priv table
piou> /usr/libexec/ mysqld: No such file or directory
piou> Installation of grant tables failed!

piou> Examine the logs in ./data for more information.
piou> =====

piou> Trying to run "./bin/mysqld --skip-grant &" gives the same error: can't find
> the file. As far as I can tell, OpenBSD comes with a
> file in /usr/lib, but there is no file in the current distribution
> (OpenBSD 2.5). Is there a file available for download somewhere (either
> through you or elsewhere), or is there a way to get around this error?

>> How-To-Repeat:

piou> Typical binary installation on FreeBSD 2.5:
shell> gunzip < mysql-VERSION-OS.tar.gz | tar xvf -
shell> ln -s mysql-VERSION-OS mysql
shell> cd mysql
shell> scripts/mysql_install_db

>> Fix:

>> Submitter-Id:	<submitter ID>
>> Originator:	Edward T. Piou
>> Organization:
piou>  ep Productions, Inc. 
>> MySQL support: none
>> Synopsis: 	can't install binary mysql-3.22.22 for OpenBSD 2.5	
>> Severity:	
>> Priority:	
>> Category:	mysql
>> Class:		
>> Release:	mysql-3.22.22 (Source distribution)

>> Environment:
piou> System: OpenBSD dhalgren 2.5 GENERIC#243 i386



Install or configure MySQL with:

CC=gcc CXX=gcc ./configure ....


mysql-3.22.22-unknown-openbsd2.5-i386 binary won't installpiou8 Aug
  • mysql-3.22.22-unknown-openbsd2.5-i386 binary won't installMichael Widenius8 Aug
  • mysql-3.22.22-unknown-openbsd2.5-i386 binary won't installsinisa8 Aug
    • Re: mysql-3.22.22-unknown-openbsd2.5-i386 binary won't installEdward T. Piou8 Aug
      • Re: mysql-3.22.22-unknown-openbsd2.5-i386 binary won't installsinisa9 Aug