List:General Discussion« Previous MessageNext Message »
From:Michael Widenius Date:August 6 1999 12:09am
Subject:Make problems: HP-UX 9.05
View as plain text  

>>>>> "lr" == lr  <lr@stripped> writes:

lr> Using HP-UX 9.05, I have successfuly made all in Docs, readline, and
lr> client.  When trying to make all in mit-pthreads, I get the fatal error
lr> message:

lr> Make: Must be a separator on rules line 18.  Stop.

lr> Below is mit-pthreads/Makefile.  The line in question starts '.OBJDIR !=
lr> ...'.  If I comment that line out, the error moves down to the next
lr> statement.

lr> I haven't worked with 'make' for a long time, and don't remember how to
lr> fix a problem like this.  Please help.

The problem is that your make is probably pretty old or has some bugs.
Get gnu make and use this instead!

lr> I would also appreciate any other tips and suggestions for making MySQL
lr> on this platform.  According to the README file, the binary distribution
lr> won't work, so I have been trying to build it from source.  I have
lr> solved a couple of problems with compilation already, but there seem to
lr> be others.

Sorry HP-UX 9.05 is a unknown beast for me.  I can only suggest that
you get gcc 2.95 and try this (I don't trust gcc 2.8.1 on HP-UX)

Make problems: HP-UX 9.05lr6 Aug
  • Make problems: HP-UX 9.05Michael Widenius6 Aug
  • Re: Make problems: HP-UX 9.05Ralf Kraudelt6 Aug