List:General Discussion« Previous MessageNext Message »
From:Michael Widenius Date:August 5 1999 12:14am
View as plain text  
>>>>> "Scott" == Scott Anderson <scott@stripped> writes:

Scott> Greetings
Scott> I just started using MySQL, in fact this is our first client we tried the
> product with. the db worked well for about 30 days and now we are having a serious
> problem. One of my tables has become corupted the table contains about 3500 rows of data.
> If i run isamchk -r it fixes the table but leaves only 10 rows of data. Does anyone know
> what went wrong, how i can keep it from happening again, and can we recover more than 10
> rows out of this table. the output for mysqlbug is inlcuded as well as some output from
> when i run isamchk tbl_name. i saw somewhere that there was a place i could ftp the table
> data for people to look at. if this is necesary please let me know where and i will have
> it there asap. 
Scott> Any help would be much appreciated thankyou!

Scott> OUTPUT of isamchk

Scott> Checking ISAM file: contest
Scott> Data records:    3514   Deleted blocks:       0
Scott> - check file-size
Scott> - check delete-chain
Scott> - check index reference
Scott> - check record links
Scott> isamchk: error: Wrong bytesec: 99-111-110 at linkstart: 0
Scott> ISAM-table 'contest' is corrupted
Scott> Fix it using switch "-r" or "-o"


The problem could be that you are using gcc 2.7.2 with -O6 when you
compiled MySQL.  Try using the binary distribution or us egcs 1.1.2 to 
compile MySQL !

Start by doing a backup of your table.  Then run:

isamchk -r contest

This should fix your table.

MySQL should not corrupt tables as long as you don't accidently kill
it. Please read the manual section: 'What to do if the server keeps
crashing' for more information about what to do!


GreetingsScott Anderson5 Aug
  • GreetingsMichael Widenius5 Aug
Re: GreetingsScott Anderson5 Aug