List:General Discussion« Previous MessageNext Message »
From:Bruce Ferrell Date:November 18 2001 5:29pm
Subject:Re: "read only" message
View as plain text  
The message means that the databse files themselves have incorrect
permissions for the user mysql is running as.

ps -ef | grep mysql will show who mysqld is running as.  Then check the
owership/permissions of the files to see if they are owned by that
user.  	I think you'll find they are not owned by the same user.

Barbara Ferrell wrote:
> i am using linux redhat 7.2.  on my home computer..  i am logged on as
> root@localhost.  i get a message that my table is "read only".  i thought
> the root user had all privileges and i cannot figure out how to give myself
> the privilege to change and alter my database and tables after i just
> created them.. i also tried to load one line of data into my empty table and
> it said "read only".  i tried GRANT ALL PRIVILEGES on *.* to root@localhost.
> that did not work.  i just installed mysql and then created the database and
> then the tables. i cannot figure out how to get into the Grant tables to
> give me all the privileges..
> ---------------------------------------------------------------------
> Before posting, please check:
>   (the manual)
>           (the list archive)
> To request this thread, e-mail <mysql-thread91626@stripped>
> To unsubscribe, e-mail
> <>
> Trouble unsubscribing? Try:


One day at a time... One second if that's what it takes
"read only" messageBarbara Ferrell18 Nov
  • Re: "read only" messageBruce Ferrell18 Nov
  • Re: "read only" messageRussell Miller18 Nov