MySQL Lists are EOL. Please join:

List:General Discussion« Previous MessageNext Message »
From:Michael Widenius Date:March 24 1999 6:15pm
Subject:Isamchk on NT
View as plain text  
>>>>> "Barry" == Barry  <barry@stripped> writes:

Barry> Hello All,
Barry> I am testing and using the shareware NT MySQL 3.21.29. I have a database
Barry> with four tables.

Barry> As a test, today I ran "Isamchk -r -v table1" on one of the tables. The
Barry> table was fine before running Isamchk, but after it was messed up. The
Barry> second (of two records) was no longer visible (verified this with the
Barry> utility MyAdmin), but when I tried to insert a record using the primary key
Barry> value that would have been assigned to the second record (Rec="R2"), it
Barry> would not let me. After a little more playing and running isamchk -ro, the
Barry> first record disappeared also.

Barry> So I tried the same things on a second table from the same database.
Barry> Essentially the same corruptions were repeated.

Barry> Should I be able to run Isamchk -e or -r or -ro on a good table and not
Barry> have the table corrupted?


The problem in this case was that MySQL had the old table open after you
had run isamchk.

To run isamchk, you should take down mysqld or do

mysqladmin refresh
isamchk ....
mysqladmin refresh

while ensuring that no one is using the checked/repaired table.

This is documented in the MySQL manual!

Isamchk on NTBarry24 Mar
  • Re: Isamchk on NTChristian Mack24 Mar
    • Re: Isamchk on NTBarry25 Mar
      • Re: Isamchk on NTMichael Widenius25 Mar
  • Isamchk on NTMichael Widenius24 Mar
Re: Isamchk on NTEd Carp24 Mar