MySQL Lists are EOL. Please join:

List:General Discussion« Previous MessageNext Message »
From:Christian Mack Date:March 24 1999 5:35pm
Subject:Re: Isamchk on NT
View as plain text  
Barry wrote:
> Hello All,
> I am testing and using the shareware NT MySQL 3.21.29. I have a database
> with four tables.
> As a test, today I ran "Isamchk -r -v table1" on one of the tables. The
> table was fine before running Isamchk, but after it was messed up. The
> second (of two records) was no longer visible (verified this with the
> utility MyAdmin), but when I tried to insert a record using the primary key
> value that would have been assigned to the second record (Rec="R2"), it
> would not let me. After a little more playing and running isamchk -ro, the
> first record disappeared also.
> So I tried the same things on a second table from the same database.
> Essentially the same corruptions were repeated.
> Should I be able to run Isamchk -e or -r or -ro on a good table and not
> have the table corrupted?
> Thanks,
> Barry.

Hi Barry

Did you stop mysql before running isamchk?
Or did you do a 'mysqladmin refresh' before isamchk?
Did you prevent any other user from using mysql while running isamchk?

If not, that's your problem.
Then it may happend, that the files wheren't up to date while isamchk tried to repair.

Hope this helped.

Isamchk on NTBarry24 Mar
  • Re: Isamchk on NTChristian Mack24 Mar
    • Re: Isamchk on NTBarry25 Mar
      • Re: Isamchk on NTMichael Widenius25 Mar
  • Isamchk on NTMichael Widenius24 Mar
Re: Isamchk on NTEd Carp24 Mar