List:General Discussion« Previous MessageNext Message »
From:Erik Price Date:November 14 2001 12:09am
Subject:mysqld shutdown
View as plain text  

Well, I solved the mystery of the missing Unix socket.  It needs to be
defined at the time the daemon is started with: 
--socket=/path/to/socket.   Well, at least in my installation it does.

But now I'm having the OPPOSITE problem -- shutting down the server
(the daemon).  I've searched the issue at length in the documentation,
as well as in DuBois' "MySQL" (New Riders), and found quite a bit of
information about shutting down the server.  One option is to use

/usr/local/mysql/bin:mysql$ mysqladmin -u root -p shutdown

But this one doesn't work for me, even though I am using the proper
password and am the proper user.  Executing this command just leaves me
hanging at the prompt (and the only way to get out of the hang is to
either suspend the job, which also has no effect).

Here's another option -- killing the process.  This doesn't work
either, surprisingly.

/usr/local/mysql/bin:mysql$ jobs
[1]+  Running                 /usr/local/mysql/bin/safe_mysqld
--socket=/usr/local/mysql/run/mysql_socket &

/usr/local/mysql/bin:mysql$ kill %1
/usr/local/mysql/bin:mysql$ jobs
[1]+  Running                 /usr/local/mysql/bin/safe_mysqld
--socket=/usr/local/mysql/run/mysql_socket &

See?  Still running.  And I've tried killing it using the PID, and that
has no effect either.

The only thing that DOES work, is

/usr/local/mysql/bin:mysql$ kill -9 17344 (where 17344 = PID)

But I don't want to do this, because the documentation and the book
suggest that using "kill -9" doesn't give the tables a chance to
properly shut down.

I would like to be able to shut down the daemon whenever I wish, and I
have not yet configured the daemon to shut down automatically at system
shutdown (or start up at system startup).  I do intend to eventually do
this, and later, when I migrate the database off of my laptop and onto
a proper server, this won't be an issue, but for right now it is.  I
don't want to have to run isamchk or myisamchk all the time and always
restore damaged tables from backups, either.

Please help me nip this problem in the bud, before I go about
populating my database with information.  I compiled MySQL from source,
version 3.22.44 onto Darwin 1.3.1 using the following configure

--prefix=/usr/local/mysql --with-comment --with-debug

Although I confess I am very new to MySQL and am not sure how to use
the debug yet.

Thanks for anyone who can help!!!

-- Erik

Microsoft e[X]tra [P]roprietary
-- Is this where you really wanted to go today ? --

Do You Yahoo!?
Find the one for you at Yahoo! Personals
mysqld shutdownErik Price14 Nov
  • Re: mysqld shutdownBill Adams14 Nov
    • Re: mysqld shutdownErik Price14 Nov
      • Re: mysqld shutdownBill Adams14 Nov
        • Re: mysqld shutdownErik Price14 Nov
        • Re: mysqld shutdownSergei Golubchik14 Nov
          • Re: mysqld shutdownErik Price14 Nov
            • Re: mysqld shutdownGerald Clark14 Nov
            • Re: mysqld shutdownDan Nelson15 Nov
              • Re: mysqld shutdownErik Price15 Nov
    • Re: mysqld shutdownMike(mickalo)Blezien14 Nov
Re: mysqld shutdownErik Price14 Nov