List:General Discussion« Previous MessageNext Message »
From:Michael Widenius Date:July 30 1999 9:43pm
Subject:insert failed with ADO
View as plain text  
>>>>> "Rehan" == Rehan Ishrat <ishrat_rehan@stripped> writes:

Rehan> MySql is installed on Linux. I created DSN on NT workstation 4.0.
Rehan> Through ADO control in VB 6.0 i tried to connect to the tables. O.K the 
Rehan> connection established and  it retrieved the records in the Data 
Rehan> Grid.Problem is that when i update/insert the records, the operation get 
Rehan> failed.
Rehan> Further information is given below.
Rehan> At Server Side i have following resources.
Rehan> O.S=Linux 2.2.7.
Rehan> WebServer=Apachi /1.3.4.
Rehan> MySql=Server version: 3.22.14 b-gamma
Rehan>        Protocol: 10
Rehan>        Connection: TCP/IP.
Rehan> Machine: intel -586
Rehan> DataBase=rehandb
Rehan> Table Name=abc
Rehan> Field1=f1 char(2)
Rehan> Field2=f2 char(2)
Rehan> At Client Side i have following.
Rehan> O.S=NT WorkStation 4.0
Rehan> DSN=TestMySql
Rehan> Odbc driver=ver=
Rehan> Programming Language=VB6.0
Rehan> Project Type=EnterPrise Edition Controls.
Rehan> Control that i use in VB to connect to Database =Microsoft ADO DataControl 
Rehan> 6.0 (OLEDB).
Rehan> Grid Control=Microsoft Data Grid Control 6.0 (OLEDB)
Rehan> References that i used = Microsoft ActiveX dataobject 2.0 Library.
Rehan> Error that i encountered during update and insert through data control and 
Rehan> grid is = [TCX][MYODBC]Table 'rehandb.f1' does not exists.
Rehan> I guessed as the above message tells that the ADO control is unaware of the 
Rehan> correct table name. because rehandb is the name of the database and not of 
Rehan> the table. It will succeed in inserting records if it founds 
Rehan> [TCX][MYODBC]Table 'abc.f1' during the operation.


Please check that you don't have the option:

Ignore # in #.table

checked in the MyODBC connect screen

Have you tried to make a MyODBC log to check which query fails?  You
can easily check if the query is ok by trying it in the 'mysql command 
line tool!

With MySQL 3.22 you can use the database.table name syntax!

insert failed with ADORehan Ishrat17 Jul
  • insert failed with ADOMichael Widenius31 Jul