MySQL Lists are EOL. Please join:

List:General Discussion« Previous MessageNext Message »
From:Barry Date:March 24 1999 2:36am
Subject:Isamchk on NT
View as plain text  
Hello All,

I am testing and using the shareware NT MySQL 3.21.29. I have a database
with four tables.

As a test, today I ran "Isamchk -r -v table1" on one of the tables. The
table was fine before running Isamchk, but after it was messed up. The
second (of two records) was no longer visible (verified this with the
utility MyAdmin), but when I tried to insert a record using the primary key
value that would have been assigned to the second record (Rec="R2"), it
would not let me. After a little more playing and running isamchk -ro, the
first record disappeared also.

So I tried the same things on a second table from the same database.
Essentially the same corruptions were repeated.

Should I be able to run Isamchk -e or -r or -ro on a good table and not
have the table corrupted?


Thanks much,

Isamchk on NTBarry24 Mar
  • Re: Isamchk on NTChristian Mack24 Mar
    • Re: Isamchk on NTBarry25 Mar
      • Re: Isamchk on NTMichael Widenius25 Mar
  • Isamchk on NTMichael Widenius24 Mar
Re: Isamchk on NTEd Carp24 Mar