List:General Discussion« Previous MessageNext Message »
From:Gerald Clark Date:July 25 2001 1:15pm
Subject:Re: Upgrade/installation problem
View as plain text  
Error 13 is permission denied.
Mysql does not own the files.
chown -R mysql /var/lib/mysql ( Or whatever )

Roger Westin wrote:

> Ok problem.
> Upgrade from 3.23.37 to 3.23.40 on linux readhat 7.0 - using rpm
> and after the uppdate I get : Cant find file ./mysql/host.frm (error: 13)
> so I copied the db and run mysql_install_db, still get the same msg,
> So I checked the error 13 = permission denined.
> So I doublecheck tthe permission, and even tried to give ugo=rwx on all the files, 
> same error.
> So Just to se if it for some reason read from another datadit i removed the datadir,
> and I get Table doesn't exists (= another error) wich tells me that
> it actualy is reading from the right datadir.
> So I tried to uninstall all the mysql rpm and installing it againg....
> same error....
> so what can be wrong....
> Ran out of clues.
> The installation has been upgraded several times before with any problems.
> /roger

Gerald L. Clark

Upgrade/installation problemRoger Westin25 Jul
  • Re: Upgrade/installation problemGerald Clark25 Jul
  • Re: Upgrade/installation problemStefan Hinz25 Jul