List:General Discussion« Previous MessageNext Message »
From:Kingsley Wright Date:March 21 1999 11:00pm
Subject:Re: Problems with MySQL Linux init.d startup
View as plain text  
The only thing that is called after the mysql script is the rc.local script
which does nothing more than change /etc/issue and set the prompt.

I tried, just for kicks, putting the mysql after rc,local, making it
absolutely last and it had no effect.

From what I gather, looking at the script, it is looking to get a "datadir"
path from a config file.  I looks for either /etc/my.cnf or $HOME/.my.cnf in
that order.   I have no such file in either directory.

I do, however, have a /root/.my.cnf but it only contains my password for
fast logons. no datadir path is being set here.  As I said in my original
post, once I am logged into the Linux box as root, I can run the *same*
script from the /etc/init.d directory and it works!  What gives?

I am not sure what you mean by "right options."  If the script is working as
root, why not during init?  Is there a permissioning problem here, I seen no
messages anywhere to that effect if is?  The system boots into multimuser
mode (run level 3) so that is not the issue..

Can anyone help me out here?  Has anyone else ever had this problem?

----- Original Message ----- :
: mysqld is in:
:      /usr/sbin/mysqld
: mysql is in:
:      /usr/bin/mysql
: databases are in:
:     /var/lib/mysql/
: There is also a directory with some scripts and stuff in:
:     /usr/share/mysql/
: There is a file /etc/rc.d/init.d/mysql which is linked to =
: /etc/rc.d/rc3.d/S98mysql which is what is run at boot time.  It looks =
: like a pretty standard stop/start a daemon type thing. =20
: The problem is that when the init.d scripts are being executed, the =
: mysql dies almost immediately after it starts.
: The /var/lib/mysql/ (hostname.err) file looks like =
: this:
: mysqld started on  Sat Mar 20 11:53:06 PST 1999
: 990320 11:53:08  /usr/sbin/mysqld: Can't find file: './mysql/user.frm' =
: (errno: 13)
: mysqld ended on  Sat Mar 20 11:53:09 PST 1999
: Funny thing is, (not knowing where it assumes the current dir is =
: exactly) /var/lib/mysql/mysql/usr.frm exists=20
: Funnier still is that when I log in as root and run the same script: =
: /etc/rc.d/init.d/mysql start, it starts up just fine with the usual 3 =
: processes and everything appears normal...  Can anyone tell me what is =
: going on here?  How do I stop it from dying at startup?
: Thanks=20
: Kingsley Wright=20
: wrightko@stripped=20
: ICQ#977267
: Hi!
: Please make sure that mysql server is called last in the init sequence
: calls, and that it it is called with right options.

: Among other things system should be in multi-user mode to function
: Sinisa

Problems with MySQL Linux init.d startupKingsley Wright21 Mar
  • Problems with MySQL Linux init.d startupsinisa21 Mar
  • Problems with MySQL Linux init.d startupsinisa21 Mar
  • Re: Problems with MySQL Linux init.d startupKingsley Wright22 Mar
  • Re: Problems with MySQL Linux init.d startup SOLVED!Kingsley Wright22 Mar