List:General Discussion« Previous MessageNext Message »
From:Gerald Clark Date:May 1 2001 1:35pm
Subject:Re: Is my table hosed?
View as plain text  
Stop the server, then myisamchk the index.

Carina C. Zona wrote:

> MySQL 3.23.33:
> This morning, one of my tables suddenly reported index corruption.  I locked
> the table, fixed with myisamchk -o, unlocked, and thought the problem was
> solved.  But it keeps on re-corrupting (I'm not even writing anything to it
> first).  Plus any query on that table which uses a "where" clause takes an
> *extremely long time to execute.  Queries that normally take .01 seconds are
> taking 10-15 *minutes*.  Or more.
> DESC TABLE shows that the indexes are all still in place.  I even tried
> dropping and re-creating an index, but that didn't seem to make a
> difference.  EXPLAIN on the queries shows that MySQL still knows to use the
> indexes that are there.  Yet obviously something is quite wrong.  One other
> odd thing: after one of the (many) repair operations, I started getting
> "disk quota filled" errors.  It turned out that a 142M file with the prefix
> "#sql" had surfaced in /tmp.  I deleted it, and things went back to
> semi-normal after that (everything working, but the table still extra slow).
> Where did that big file come from?  My whole db is only 8M, the corrupted
> table is only 4M, so does it sound right that a 142M temp file was somehow
> generated..?
> Odd.  Anyway, I'm hoping someone recognizes this problem and can point me
> toward the right section of the manual to learn how to fix it.  <fingers
> crossed that the table is still recoverable...>
> Thank you!
> ---------------------------------------------------------------------
> Before posting, please check:
>   (the manual)
>           (the list archive)
> To request this thread, e-mail <mysql-thread72744@stripped>
> To unsubscribe, e-mail
> <>
> Trouble unsubscribing? Try:

Gerald L. Clark

Is my table hosed?Carina C. Zona1 May
  • Re: Is my table hosed?Gerald Clark1 May