List:General Discussion« Previous MessageNext Message »
From:Michael Widenius Date:July 5 1999 8:47am
Subject:RE: Problem with SPARC/Linux
View as plain text  

As you are using RedHat 5.1, you should upgrade your glibc libraries
to the newest possible glibc 2.0 version.

>>>>> "Joshua" == Joshua Gilbert <jgilbert@stripped> writes:

Joshua> No, mysqld was definately running. I have tried starting it through the
Joshua> safe_mysqld script, as well as manually by just running the mysqld binary.
Joshua> It starts okay, but then it doesn't seem to do anything.

Joshua> Here's what I did:

Joshua> - Compiled and installed mysql
Joshua> - Ran mysql_install_db -- hangs -- Ctrl-C'ed it
Joshua> - Started safe_mysqld.
Joshua> - Tried mysql and mysqladmin -- both report that the unix socket is not
Joshua> active, then if I explicitely give them the hostname with "-h" it reports it
Joshua> cannot connect via TCP/IP
Joshua> - Tried telnetting to port 3306. Connection refused.
Joshua> - Killed safe_mysqld (mysqld process died with it).
Joshua> - Started mysqld manually.
Joshua> - Tried mysql, mysqladmin, and telnet again. Same problems.

Joshua> I've tried it twice with clean mysql distributions. Nothing seems to work.

Joshua> It should be noted that mysqld only shows one running process when I do a
Joshua> 'ps'. I've heard (although I could very easily be mistaken) that Linux is
Joshua> supposed to use a seperate process for each thread. Could this be a
Joshua> threading problem?

Yes; ps should show 3 threads on Linux

Problem with SPARC/Linuxjosh5 Jul
  • Re: Problem with SPARC/LinuxSasha Pachev5 Jul
    • RE: Problem with SPARC/LinuxJoshua Gilbert5 Jul
      • RE: Problem with SPARC/LinuxMichael Widenius5 Jul