List:General Discussion« Previous MessageNext Message »
From:Michael Widenius Date:June 28 1999 8:20pm
Subject:sqladmin returns error and no socket can be
View as plain text  
>>>>> "root" == root  <root@stripped> writes:

>> Description:
root> 	Well the mysql_install_db worked out this time and bin/safe_mysqld
root> & also worked and the daemon is running. I can't find a socket file
root> though.


This is because you are configuring MySQL with 'mit-threads'.  In this
case you will NOT get an socket file (as mit-threads doesn't support
Unix sockets)

root> 	Also, when I run mysqladmin version I get an error. Here it is;
root> # ./bin/safe_mysqld &

root> [1] 16338
root> # Starting mysqld daemon with databases from /home/.MySQL/data

root> # ./bin/mysqladmin version
root> ./bin/mysqladmin: connect to server at 'localhost' failed
root> error: 'Can't connect to local MySQL server through socket
root> '/tmp/mysql.sock' (2)
root> '
root> Check that mysqld is running and that the socket: '/tmp/mysql.sock'
root> exists!
root> # ls
root> So as I said mysqld is running but I the socket doesn't exist. 

Try instead:

mysqladmin -h 'hostname' version

You can avoid having to specify hostname every time by creating the


with the following information:



sqladmin returns error and no socket can beroot19 Jun
  • sqladmin returns error and no socket can beJani Tolonen23 Jun
  • sqladmin returns error and no socket can beMichael Widenius29 Jun