List:General Discussion« Previous MessageNext Message »
From:Paul DuBois Date:June 26 1999 6:03pm
Subject:Re: Error 2002 - No socket
View as plain text  
At 12:56 PM -0500 6/26/1999, wrote:
>This message was sent from by "James" <captain@stripped>
>Be sure to reply to that address.
>I installed mysql about 3 weeks ago and it has been running fine up until
>last night.
>When i tried to connect to the server last night it said
>ERROR 2002: Can't connect to local MySQL server through socket
>'/tmp/mysql.sock' (2)
>I tried to start the server by using 'bin/safe_mysqld &' but it gave me
>this error
>'su-2.02# A mysqld process already exists'
>I did a 'ps' command and seen these 2 processes running
>68892  p0- T      0:00.01 /bin/sh bin/safe_mysqld
>68903  p0- S      0:19.00 /usr/local/libexec/mysqld --basedir=/usr/local
>I tried to kill the processes but no matter how many times I try, they
>never die.
>I tried to shutdown the server thru 'bin/mysqladmin -u foo -pbar shutdown'
>but it gives me the 'Error 2002 no socket' error.
>Anyone know whats going on?

Does /tmp/mysql.sock exist?  If not, do you have some sort of cron
job that removes files from /tmp?

Try connecting to the server using mysqladmin -h
to force a TCP/IP connection rather than going through the UNIX domain

Paul DuBois, paul@stripped
Northern League Chronicles:
Error 2002 - No socketGeocrawler.com26 Jun
  • Re: Error 2002 - No socketPaul DuBois26 Jun