List:General Discussion« Previous MessageNext Message »
From:Jack McKinney Date:June 28 2000 3:45pm
Subject:Using alternate port?
View as plain text  

     Searching for keywords for this in the mailing lists is fruitless,
so I thought I'd post here.  I am using 3.22.26a under Debian 2.1 linux
with kernel 2.0.38.  I cannot upgrade to later versions because they do
not work properly with glibc 2.0.6, and I cannot upgrade my system at
this time.
     I am trying to use ssh to forward the mysql port and have discovered
that the '-P' and '--port=' options do not work.  If I misspell --port,
it gives me a command line syntax error, but when I spell it right, it
still connects to port 3306.
     There is no question that I am forwarding the port incorrectly.
I am on machine foo, and have mysql servers running on both foo and
bar.  I also have POP servers.
     On foo, I run:

ssh bar -L 10000:bar:110 sleep 3600

     Then, on foo, I 'telnet localhost 10000'.  The pop server answers
claiming to be 'bar', so the port forwarding works.
     Now, I run on foo:

ssh bar -L 11000:bar:3306 sleep 3600

     Then, also on foo, I run:

mysql -hlocalhost -P11000 -pmypass dbonbar

     I get a no-such-database error.  dbonbar is a database on bar's
mysql server, but it is not on foo's.  If I try to connect and specify
a database that is on foo, it works:

mysql -hlocalhost -P11000 -pmypass dbonfoo

     So, the port forwarding syntax is correct, since telnetting to the
local port forward to the remote POP port, but mysql seems to want to
connect to 3306 on localhost and never 11000 as specified.
     Is this a known bug fixed in a later version?

- --
"Of course its your fault. Everything that goes wrong  Jack McKinney
here is your fault. It says so in your contract."      jackmc@stripped
         -Quark to his brother Rom, DS9      
F4 A0 65 67 58 77 AF 9B  FC B3 C5 6B 55 36 94 A6

Version: 2.6.2

Using alternate port?Jack McKinney28 Jun