List:General Discussion« Previous MessageNext Message »
From:Douglas Brantz Date:April 5 2000 2:30pm error with connect question?
View as plain text  
Here is a common question.

Installed the latest Mysql onto Redhat 6.1 and the mysql database is
working great.
My problem begins when I try to insert data through the web forms.

Actually had this problem before and didn't write down what I did to fix
it, so forgive me for
bringing it up again almost a year later.

Here is how it all starts:
I ran one of my .pl files from the command line and it gives the long
error about not being able to find in
the path.
I look at my script and I am using "use Mysql;" near the top.
I do a find for on the server - nothing found
I do a search for m) on the server and this finds
I copy to and make a link to it with cp ln
Now I run the same script and I get different errors that state - I have
called the method correctly but error with connect?
Sorry, don't have the exact error message - its not that long of an
error message.

here is the connect script:
my $dbh = Mysql->connect("Localhost","database",$usrn,$pass2);

my $command="";

In the permissions table does case matter?  I have localhost instead of
Localhost in all permissions tables to acces the db?

I think I actually solved this by re-installing the Mysql msql module
again inside the perl directory, but wondered if anyone can
shed and light on this problem?

This time I will print out the solution.




Douglas Brantz
Computer Consultant
Fine & Applied Arts
Appalachian State University
Boone, NC 28608

828-262-6312 FAX
828-262-6549 OFFICE

Thread error with connect question?Douglas Brantz5 Apr
  • Re: error with connect question?sasha5 Apr
  • Re: error with connect question?Thimble Smith6 Apr