List:General Discussion« Previous MessageNext Message »
From:Massimo Ferrario Date:May 5 1999 8:00am
Subject:Re: mysql.socks error
View as plain text  
At 14.32 04/05/99 -0400, Sean Hynes wrote:
>We are new to mysql. We were successful at creating and setting up mysql on 
>Linux machine.  When we tried to transport a mysql database from an NT
>machine it screwed 
>things up. We tried to copy the files into a directory or a shell database
>on the 
>linux machine in var/lib.
Hmm ... I think the correct procedure for this task is: 
1) use mysqldump.exe on the NT box to dump the database, 
   [mysqldump database >database.dmp]
2) transfer the resulting ascii files to the linux box (I suggest ftp ascii
transfer to avoid
    problems with newlines/linefeeds]
3) feed the mysql client on the linux box with the resulting text file! 
   [mysql database <database.dmp]

You can safely copy table files between boxes using the same operating
system (eg linux-> linux).

>After that it screwed up some stuff: We cannot access any database, when 
>try to we get: 
>error 2002: Can't connect to local mysql server through socket 
>"'/'var/lib/mysql/mysql.sock" (111)
Didi you read the on-line manual about this error? See section 17 "Problems
and common errors" at, and
section 4 at
I do not know if mysql daemon likes the '/' part of the socket file name: I
think the name should be "/var/lib/mysql/mysql.sock".

>We go to mysql.sock file and there are no contents. 
>What does this file contain? Can we edit through Pico?
I strongly suggest against this action: it is a socket, not a regular file:
perhaps you should read something more about linux/unix!

Hope this helps.

Massimo Ferrario
Inforeti snc
via Pellizzo, 39 - 35100 Padova (Italy)
mysql.socks errorSean Hynes5 May
  • Re: mysql.socks errorMassimo Ferrario5 May