List:General Discussion« Previous MessageNext Message »
From:Jørn Dahl-Stamnes Date:January 14 2014 5:36pm
Subject:Crash after shutdown/restart
View as plain text  

Got a test server with version 5.5.20. I wanted to unmount/mount the disk 
where the innodb files was located, so I did a shutdown followed by unmount, 
then a mount before I tried to start the MySQL server. But it did not work as 
shown in the log below.

I wanted to unmount the disk since I wanted to change the 'defaults' 
in /etc/fstab with 

What could cause this? Guess I have to recreate the files and start all over 

# Older message from the error file showing the version.
Version: '5.5.20-log'  socket: '/tmp/mysql.sock'  port: 3306  Source 

# Shutdown messages
140114 18:14:53 [Note] Event Scheduler: Purging the queue. 0 events
140114 18:14:53  InnoDB: Starting shutdown...
140114 18:17:58  InnoDB: Shutdown completed; log sequence number 2230197670580
140114 18:17:58 [Note] /usr/local/mysql/bin/mysqld: Shutdown complete

# Restart after umount/mount.
140114 18:17:59 mysqld_safe mysqld from pid 
file /usr/local/mysql/data/ ended
140114 18:20:05 mysqld_safe Starting mysqld daemon with databases 
from /usr/local/mysql/data
140114 18:20:05 InnoDB: The InnoDB memory heap is disabled
140114 18:20:05 InnoDB: Mutexes and rw_locks use GCC atomic builtins
140114 18:20:05 InnoDB: Compressed tables use zlib 1.2.5
140114 18:20:05 InnoDB: Initializing buffer pool, size = 25.0G
140114 18:20:08 InnoDB: Completed initialization of buffer pool
140114 18:20:08 InnoDB: Error: data file /data/mysql/data/ibdata3 uses page 
size 1024,
140114 18:20:08 InnoDB: but the only supported page size in this release 
140114 18:20:08 InnoDB: Could not open or create data files.
140114 18:20:08 InnoDB: If you tried to add new data files, and it failed 
140114 18:20:08 InnoDB: you should now edit innodb_data_file_path in my.cnf 
140114 18:20:08 InnoDB: to what it was, and remove the new ibdata files InnoDB 
140114 18:20:08 InnoDB: in this failed attempt. InnoDB only wrote those files 
full of
140114 18:20:08 InnoDB: zeros, but did not yet use them in any way. But be 
careful: do not
140114 18:20:08 InnoDB: remove old data files which contain your precious 
140114 18:20:08 [ERROR] Plugin 'InnoDB' init function returned error.
140114 18:20:08 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE 
140114 18:20:08 [ERROR] Unknown/unsupported storage engine: InnoDB
140114 18:20:08 [ERROR] Aborting

Jørn Dahl-Stamnes
Crash after shutdown/restartJørn Dahl-Stamnes14 Jan
  • Re: Crash after shutdown/restartJesper Wisborg Krogh14 Jan
    • Re: Crash after shutdown/restartJørn Dahl-Stamnes22 Jan
      • Re: Crash after shutdown/restartMorgan Tocker22 Jan
        • Re: Crash after shutdown/restartJørn Dahl-Stamnes18 Feb
          • Re: Crash after shutdown/restartMorgan Tocker18 Feb