List:General Discussion« Previous MessageNext Message »
From:fatcharly Date:February 23 2012 3:37pm
Subject:problem after update with a second node (no cluster problem)
View as plain text  

I´m running a mySQL-Cluster with drbd/pacemaker/heartbeat on two centOS 5.7. The old
version was a mysql-server-5.0.77-4.el5_6.6 the new is mysql-server-5.0.95-1.el5_7.1. 
I tried to update the system with less downtime, so first update via yum was on the
passive node (2 drbd-devices as slave, no mysqld started) and was no problem also after
reboot eveything looked fine. Then I tried to switch the database over to the passive
second (updated) node. But the mysqld was unable to start on that machine. I did the
update (and reboot) also on the active node and there is no problem with the mysqld.
This is a part of /var/log/mysqld.log

120223 15:46:44  InnoDB: Page checksum 1575996416, prior-to-4.0.14-form checksum 1371122
InnoDB: stored checksum 0, prior-to-4.0.14-form stored checksum 0
InnoDB: Page lsn 0 0, low 4 bytes of lsn at page end 0
InnoDB: Page number (if stored to page already) 0,
InnoDB: space id (if created with >= MySQL-4.1.1 and stored already) 0
120223 15:46:44InnoDB: Error: trying to access a stray pointer 0x80002aaaae217ff8
InnoDB: buf pool start is at 0x2aaaae208000, end at 0x2aaac6208000
InnoDB: Probable reason is database corruption or memory
InnoDB: corruption. If this happens in an InnoDB database recovery, see
InnoDB: how to force recovery.
120223 15:46:44InnoDB: Assertion failure in thread 47112793548384 in file ./../include/b
uf0buf.ic line 268
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: about forcing recovery.
120223 15:46:44 - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 16384000 Kbytes
of memory
Hope that's ok; if not, decrease some variables in the equation.

Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
frame pointer is NULL, did you compile with
-fomit-frame-pointer? Aborting backtrace!
The manual page at contains
information that should help you find out what is causing the crash.
120223 15:46:44  mysqld ended

Any suggestions are welcome

kind regards


problem after update with a second node (no cluster problem)fatcharly23 Feb