List:General Discussion« Previous MessageNext Message »
From:Suresh Kuna Date:January 25 2012 4:09am
Subject:Re: RES: Force drop table
View as plain text  
Enable the option innodb_force_recovery =1 in my.cnf file, restart the
database, ( can try upto 4 depending on the description below url ) and
take the dump of all the innodb tables, remove the ibdata and data file
belongs to innodb and re-import. It should be fine.

Suresh Kuna

2012/1/24 Suporte Avanutri <suporte2@stripped>

> I've tried this before, but the server stills going down. The first error
> is always this:
> Couldn't execute 'SELECT /*!40001 SQL_NO_CACHE */* FROM 'usuario': Lost
> connection to MySQL server during query (2013)
> This is followed by other similar errors: "couldn't execute one thing",
> couldn't execute another thing, etc".
> I've got the error while trying to execute this: mysqldump -u USER -pPASS
> --force --databases DATABASE (and tried --all-databases too).
> Thanks in advance for the help, guys. I'm starting to learn this thing by
> myself, your help has great value to me.
> -----Mensagem original-----
> De: Johan De Meersman [mailto:vegivamp@stripped]
> Enviada em: terça-feira, 24 de janeiro de 2012 13:01
> Para: Suporte Avanutri
> Cc: Shafi AHMED; mysql@stripped
> Assunto: Re: RES: Force drop table
> ----- Original Message -----
> > From: "Suporte Avanutri" <suporte2@stripped>
> > To: "Shafi AHMED" <shafi.ahmed@stripped>, mysql@stripped
> > Sent: Tuesday, 24 January, 2012 3:43:36 PM
> > Subject: RES: Force drop table
> >
> > 120124 12:29:28  InnoDB: Error: table `avanutri/obras` does not exist in
> the InnoDB internal
> > InnoDB: data dictionary though MySQL is trying to drop it.
> > InnoDB: Have you copied the .frm file of the table to the
> > InnoDB: MySQL database directory from another database?
> That's a pretty good question it's asking :-)
> Earlier in your log it mentions that InnoDB wasn't shut down properly -
> did it crash while you were deleting that table, by any chance?
> Shut the service down, delete the file <mysqldatadir>/avanutri/obras.frm
> from disk and restart the service; the table will be gone. There shouldn't
> be any other files named obras.<something> if all is well.
> If you can, it is probably also a good idea to make a full dump of all the
> databases and reinitialize the InnoDB tablespaces - there may still be
> internal references or pages allocated to that table. Check the online
> manual for more information on doing that.
> --
> Bier met grenadyn
> Is als mosterd by den wyn
> Sy die't drinkt, is eene kwezel
> Hy die't drinkt, is ras een ezel
> --
> MySQL General Mailing List
> For list archives:
> To unsubscribe:

Suresh Kuna

Force drop tableSuporte Avanutri24 Jan
  • RE: Force drop tableShafi AHMED24 Jan
  • RES: Force drop tableSuporte Avanutri24 Jan
    • Re: RES: Force drop tableJohan De Meersman24 Jan
      • RES: RES: Force drop tableSuporte Avanutri24 Jan
        • Re: RES: Force drop tableSuresh Kuna25 Jan
          • RES: RES: Force drop tableSuporte Avanutri25 Jan
            • Re: RES: RES: Force drop tableJohan De Meersman25 Jan
              • RES: RES: RES: Force drop tableSuporte Avanutri26 Jan
                • Re: RES: RES: Force drop tableTodd Lyons26 Jan
                  • Re: RES: RES: Force drop tableJohan De Meersman26 Jan
                    • RES: RES: RES: Force drop tableSuporte Avanutri26 Jan
        • Re: RES: Force drop tableTodd Lyons25 Jan
          • Re: RES: Force drop tableTodd Lyons25 Jan