List:General Discussion« Previous MessageNext Message »
From:Martin Mueller Date:November 12 2011 8:13pm
Subject:problem with installing MySQL 5.5 on OS Lion
View as plain text  
I had MySQL 5.5.15 running on OS X Lion, deleted it, and tried to install
5.5.17. I have run into problems that I cannot  solve.

To begin with the end, I can run start mysqld with the skip-grant-tables
option and connect with mysql.  If I issue the command

select * from mysql

the result returns an empty set. This squares with the following finding. I
had thought that lost passwords caused problems and ran  the procedure for
updating the root password that is set forth in the MySQL documentation. The
procedure executes, except that it says that 0 rows were updated. So I
assume that the user account root does not exist on the machine. There is a
mysql user account on my Mac, but there may not be a mysql user entry in the
user table. 

If I try to connect to the server with the mysql command when the server is
started in the ordinary fashion I get the error message

Access denied for user 'martin'@'localhost' (using password: NO)

ditto for commands like

mysql ­p ­u  root
mysql ­u root

and the like.

I should add that I followed Rob Allen's instructions for completely
uninstalling previous versions, and theoretically speaking there should be
no traces of earlier passwords on my system. But I'm not sure.

I should add that I also followed the Post-installation steps inPaul
Dubois's MySQL, and I noticed something odd. According to him, if you have a
.tar package you need to run the mysql_install_db script. If you have a .dmg
package, the installer runs it for you. When the .dmg package had the
problems I described above, I tried a fresh installation from the .tar
package. But the command
bin/mysql_install_db ¬čuser=mysql  does not work , and in fact there is no
script by that name in the /usr/local/mysql/bin directory.

In short, in my installation there seems a gap between mysql and mysql, and
I can't find any good explanations for what I might have done wrong or how I
could fix it. 

I'll be grateful for any help.

problem with installing MySQL 5.5 on OS LionMartin Mueller12 Nov
  • Re: problem with installing MySQL 5.5 on OS LionTim Johnson13 Nov