List:General Discussion« Previous MessageNext Message »
From:Philippe Mokrani Date:June 17 2011 5:53pm
Subject:Error when installing mysql-5.5.9 server on Linux Redhat OS
View as plain text  


I tried to install  mysql-5.5.9 server on  Redhat 2.6.18-194.el5  x86_64
GNU/Linux  operating system  using the binary distribution  from


After installed the above archive in  a  "/moteurs"   directory, and
executed the following installation commands under root:


# unzip

# cd mysql-5.5.9

# chown -R mysql .

# chgrp -R mysql .

# scripts/mysql_install_db --user=mysql


I have the following error messages:


Installing MySQL system tables...

110617 19:46:25 [ERROR] ./bin/mysqld: unknown variable

110617 19:46:25 [ERROR] Aborting


110617 19:46:25 [Note] ./bin/mysqld: Shutdown complete


Installation of system tables failed!  Examine the logs in

./data for more information.


You can try to start the mysqld daemon with:


    shell> ./bin/mysqld --skip-grant &


and use the command line tool ./bin/mysql

to connect to the mysql database and look at the grant tables:


    shell> ./bin/mysql -u root mysql

    mysql> show tables


Try 'mysqld --help' if you have problems with paths.  Using --log

gives you a log in ./data that may be helpful.


Please consult the MySQL manual section

'Problems running mysql_install_db', and the manual section that

describes problems on your OS.  Another information source are the

MySQL email archives available at


Please check all of the above before mailing us!  And remember, if

you do mail us, you MUST use the ./bin/mysqlbug script!



No log file was created in  ./data directory.

I have tried all the actions mentioned on the above messages,  I have read
the documentation, I have searched for the error message  [ERROR]
./bin/mysqld: unknown variable 'default-character-set=latin1' ,  but without


May have I help ?


Best regards,

Philippe Mokrani






Error when installing mysql-5.5.9 server on Linux Redhat OSPhilippe Mokrani17 Jun
  • Re: Error when installing mysql-5.5.9 server on Linux Redhat OSReindl Harald17 Jun