List:General Discussion« Previous MessageNext Message »
From:Reindl Harald Date:April 2 2011 11:22am
Subject:Re: Mysql Bug 04/01/11:
View as plain text  

Am 02.04.2011 02:18, schrieb Thomas Dineen:

> The following error occurs:
> 110401 16:42:30 [ERROR] /usr/local/mysql/libexec/mysqld: Can't find file:
> './mysql/host.frm' (errno: 13)

BTW: you know google?
"Can't find file: './mysql/host.frm' (errno: 13)"
so this is a permissions-problem

i guess there is a data-dir in the tar.gz you "installed"
as root and you did not change its permissions

> Keep in mind that I have tried several dozen experiments over many late hours
> with a version host.frm from a older version of mysql with NO success! I have
> tried putting it in every possible location. Using 777 file permissions.

you should not blind copy files without any idea what you are doing

> root@Sun# pwd
> /usr/local/mysql
> root@Sun# ls
> bin         info        man         mysql-test  var
> host.frm    lib         my.cnf      share
> include     libexec     mysql       sql-bench

delete the host.from from here and everywhere you placed it
and please open your eyes if you too lazy read documentations

you see the folder "var"?

RTFM (google: "mysql /usr/local default datadir"):

If you get Errcode 13 (which means Permission denied) when starting mysqld, this means
that the privileges of the
data directory or its contents do not permit server access. In this case, you change the
permissions for the
involved files and directories so that the server has the right to use them. You can also
start the server as root,
but this raises security issues and should be avoided.

On Unix, change location into the data directory and check the ownership of the data
directory and its contents to
make sure the server has access. For example, if the data directory is
/usr/local/mysql/var, use this command:

shell> ls -la /usr/local/mysql/var

If the data directory or its files or subdirectories are not owned by the login account
that you use for running
the server, change their ownership to that account. If the account is named mysql, use
these commands:

shell> chown -R mysql /usr/local/mysql/var
shell> chgrp -R mysql /usr/local/mysql/var

Attachment: [application/pgp-signature] OpenPGP digital signature signature.asc
Mysql Bug 04/01/11Thomas Dineen2 Apr
  • Re: Mysql Bug 04/01/11Jigal van Hemert2 Apr
  • Re: Mysql Bug 04/01/11Reindl Harald2 Apr
    • Re: Mysql Bug 04/01/11Claudio Nanni2 Apr
      • Re: Mysql Bug 04/01/11Reindl Harald2 Apr
  • Re: Mysql Bug 04/01/11: Harald2 Apr
Re: Mysql Bug 04/01/11Claudio Nanni2 Apr
  • Got It; Thank You; Re: Mysql Bug 04/01/11Thomas Dineen2 Apr