List:General Discussion« Previous MessageNext Message »
From:Reindl Harald Date:April 2 2011 10:45am
Subject:Re: Mysql Bug 04/01/11
View as plain text  
Am 02.04.2011 02:18, schrieb Thomas Dineen:
>> Gentlemen:
>> - Keep in mind that I have approximately 50  hours into this Mysql server install
> and still no
>> results!

what have you done the whole time?
have you tried RTFM?

we are not here to guide a blind one trough a basic setup
because at the end you have something running and understodd

sounds like you never before had used mysql and missing
all the basics from the first chapters in the well written documentation

>> - Regarding the Sun Freeware package mysql-5.0.67-sol10-x86-local.gz
>> - When installed and started with the following command:
>> /usr/local/mysql/bin/mysqld_safe --user=mysql &
>> The following error occurs:
>> 110401 16:42:30 [ERROR] /usr/local/mysql/libexec/mysqld: Can't find file:
> './mysql/host.frm' (errno: 13)

you should read the manuals or use a operating system with packages
which are idiot-proof, fedora does this for you:

if [ ! -d "$datadir/mysql" ] ; then
 # First, make sure $datadir is there with correct permissions
 if [ ! -e "$datadir" -a ! -h "$datadir" ]
  mkdir -p "$datadir" || exit 1
 chown mysql:mysql "$datadir"
 chmod 0755 "$datadir"
 [ -x /sbin/restorecon ] && /sbin/restorecon "$datadir"
 # Now create the database
 action $"Initializing MySQL database: " /usr/bin/mysql_install_db --datadir="$datadir"
 chown -R mysql:mysql "$datadir"
 if [ $ret -ne 0 ] ; then
  return $ret

>> 1) Please identify where the missing file can be found, 
>> keeping in mind that I just installed and have no backup 
>> (of the current rev.)

they CAN NOT BE FOUND if you have a fresh install and not used "mysql_install_db"
and WHERE they are created depends on your configuration as said yesterday

let me guess: you even have not spent any second for your my.cnf?
> [mysqld]
> datadir = /where/ever/you/want/your/databases/jesus/christ

on my system typing mysql_ followed with 2 x TAB brings a list of commands
since you think you must not use a environments package-system why
in the world do you not look in your bin-folder at /usr/local/mysql/
and read some docs to understand that the mysql-database is the userdb

[root@srv-rhsoft:~]$ mysql_
mysql_client_test           mysql_convert_table_format  mysql_fix_extensions       
mysql_tzinfo_to_sql         mysql_upgrade_replication   mysql_zap
mysql_config                mysql_find_rows             mysql_install_db           
mysql_upgrade               mysql_waitpid

Attachment: [application/pgp-signature] OpenPGP digital signature signature.asc
Mysql Bug 04/01/11Thomas Dineen2 Apr
  • Re: Mysql Bug 04/01/11Jigal van Hemert2 Apr
  • Re: Mysql Bug 04/01/11Reindl Harald2 Apr
    • Re: Mysql Bug 04/01/11Claudio Nanni2 Apr
      • Re: Mysql Bug 04/01/11Reindl Harald2 Apr
  • Re: Mysql Bug 04/01/11: Harald2 Apr
Re: Mysql Bug 04/01/11Claudio Nanni2 Apr
  • Got It; Thank You; Re: Mysql Bug 04/01/11Thomas Dineen2 Apr