List:General Discussion« Previous MessageNext Message »
From:ML Date:December 22 2009 1:35am
Subject:MySQL running, but I cannot connect
View as plain text  
Hi All,

MySQL 5.0.77 on CentOS 5.4

MySQL is running, my Wordpress stuff is working, but I cannot connect to the server from
my house. 

I checked the firewall and that is successfully allowing the passage.

I checked the firewall on the server and that has 3306:tcp allowed.

When I try to connect I get an error (4) which when I google says: "Interrupted System
I have tried using the MySQL Workbench and other client software.

If I look in /var/log/mysqld.log I dont see anything but the fact the server started. 

I tried stopping mysql with /etc/init.d/mysqld stop

Then starting with mysqld_safe --init-file=/tmp/code.txt &

Where code.txt contains:

UPDATE mysql.user SET Password=PASSWORD('BabyToad09') WHERE User='root';
GRANT ALL ON mysql.* to 'root'@'';
GRANT ALL ON mysql.* TO 'root'@'localhost';
GRANT ALL ON mysql.* TO 'root'@'my home IP';

and I still cannot connect. 

What am I doing wrong? What can I check for? Things work, just not for me from home.


MySQL running, but I cannot connectML22 Dec
  • Re: MySQL running, but I cannot connectHiromichi Watari22 Dec