List:General Discussion« Previous MessageNext Message »
From:walter harms Date:April 28 2009 8:01am
Subject:Re: Building 5.1 on Tru64 5.1b
View as plain text  

Didier Godefroy schrieb:
> Hello all,
> I've been having troubles building mysql on Tru64 v5.1b.
> I tried several versions and there are always some kind of issues with
> undefined symbols and things to be changed in the source to allow the build
> to continue.
> Lately I've been trying to get 5.1.33 compiled, and after many different
> tries and slight alterations in some headers, I was able to get it compiled
> using gcc 4.0.2, but then I get lots of unaligned access warnings all the
> time, both from the server and the client, plus I can't get the test suite
> to run, so I can't even trust it.
> I was hoping that if I could get a successful build not using gcc and only
> the native compiler, perhaps those unaligned access errors would go away,
> but I can't get the build to finish, even now with the latest 5.1.34 source.
> The issues I'm facing now are related to pthreads and it makes no sense to
> me.
> What is happening is that a couple of identifiers are undefined:
> Making all in csv
> gmake[2]: Entering directory
> `/usr/local/mysql5/src/mysql-5.1.34/storage/csv'
> source='' object='libcsv_a-transparent_file.o' libtool=no
> \
>     DEPDIR=.deps depmode=tru64 /bin/bash ../../depcomp \
>     cxx -DHAVE_CONFIG_H -I. -I../../include -I../../include -I../../include
> -I../../regex -I../../sql -I.  -pthread -I/usr/local/ssl/include  -O4
> -DSNPRINTF_RETURN_TRUNC -I/usr/include/cxx -I/usr/include/cxx_cname
> -I/usr/include -I/usr/include.dtk -c -o libcsv_a-transparent_file.o `test -f
> '' || echo './'`
> cxx: Error: ../../sql/log.h, line 140: identifier "pthread_mutex_destroy" is
>           undefined
>   ~st_log_info() { pthread_mutex_destroy(&lock);}
> -------------------^
> cxx: Error: ../../sql/log.h, line 401: identifier "pthread_mutex_unlock" is
>           undefined
>   inline void unlock_index() { pthread_mutex_unlock(&LOCK_index);}
> -------------------------------^
> cxx: Info: 2 errors detected in the compilation of "".
> gmake[2]: *** [libcsv_a-transparent_file.o] Error 1
> I think it makes no sense that pthread_mutex_destroy and
> pthread_mutex_unlock are undefined while others like pthread_mutex_lock are
> not, and they're all defined in pthread.h which must be getting included
> because all other identifiers are defined, except those 2.
> Those errors didn't show up with gcc, but with cc/cxx they're stopping the
> build. Why?
> Will the unaligned access warnings go away if I get the build done
> successfully with cc/cxx ???
> At least I need this build to finish so I can run it and try to get the test
> suite to finally work.

hi Didier,
1. i do not work with True64
but i run mysql on 64bit Intel therefore i assume that mysql is 64bit clean.
What you are missing is the posix thread library. On linux this is with glibc.

I assume that you cc/ld need some special options to find it.

Asking google shows:
Programmers Manual for True64

The mysql documentation says that True64 need special options to configure:

If you find more issues please update the mysql documentation. These days there is
a monoculture of intelboxes and linux but good programms should be tested on more.


Building 5.1 on Tru64 5.1bDidier Godefroy27 Apr
  • Re: Building 5.1 on Tru64 5.1bwalter harms28 Apr
    • Re: Building 5.1 on Tru64 5.1bDidier Godefroy28 Apr
      • Re: Building 5.1 on Tru64 5.1bJoerg Bruehe28 Apr
        • Re: Building 5.1 on Tru64 5.1bJoerg Bruehe28 Apr
        • Re: Building 5.1 on Tru64 5.1bDidier Godefroy28 Apr