List:General Discussion« Previous MessageNext Message »
From:mikesz Date:January 14 2009 10:36am
Subject:default storage engine
View as plain text  
Hello mysql,

Greetings in the New Year to everyone. Hope for only good things...

I have been using a WAMP for maybe 5 years, started with Apache2Triad
and eventually evolved to WAMPSERVER which is what I am running now.
Over the years, I have upgraded my server many times and the procedure
that has always worked was to do a clean install and "drop" my data
into the data folder, fire it up and every thing works. I did have a
hiccup when I switched from Apache2Triad because WAMPSERVER defaults
to INNODB and ALL my work is MYISAM so after I figured out that I just
need to change the default storage engine, everything worked as
expected, copy the files, fire it up and it works. THIS TIME, I have a
real problem because the default storage engine has disappeared from
the my.ini file and if I put it in MySQL does not even start anymore.

Not only that, when I copy the database files into the data folder,
many of them seem to be corrupted now for some unknown reason.

When I do a diff on the my.ini file the new one looks nothing at all
like the previous version so my question is what happened? If anyone

Best regards,
 mikesz                          mailto:mikesz@stripped

default storage enginemikesz14 Jan
  • Re: default storage engineWalter Heck14 Jan
    • Re: default storage engineClaudio Nanni14 Jan