List:General Discussion« Previous MessageNext Message »
From:Todd M. Boyd Date:June 12 2008 3:09pm
Subject:RE: Function Still Not Working
View as plain text  
> -----Original Message-----
> From: Martijn Tonies [mailto:m.tonies@stripped]
> Sent: Thursday, June 12, 2008 6:23 AM
> To: MySQL List
> Subject: Re: Function Still Not Working
> Hey,
> > Sorry for posting this again, but I got only one response last time,
> and
> I'm
> > still having the problem.  I spent HOURS the other day manually
> > through the data and Properizing these things by hand. I don't want
> to do
> > that again if I can avoid it.  If anyone has any clues on this one,
> would
> > appreciate it.

---8<--- snip

> > It's a very simple function used to properize a string sent to it.
> When I
> do
> > a simple SELECT ProperCase('JESSE'); it returns "JESSE" on our
> that
> > is running 5.0.17-nt-log. On another server that I've got, running
> > 5.0.51a-community-nt, this function returns "Jesse" as it should.
> >
> > The only difference that I can think of is the version. Is there a
> problem
> > with the older version that would cause this function not to work
> properly?
> Any difference in default collation?

I am curious about that, as well. It brings to mind a discussion that
happened on this list last week (I believe) about case
sensitive/insensitive use of LIKE. I believe the synopsis was that
tables are either created as case-insensitive, or the search needs to be
specified as case sensitive (with BINARY).

Could this be a similar issue, perhaps? One table is specifically
case-insensitive with regard to the function, and the other is not?

Just spit-balling...

Todd Boyd
Web Programmer

Function Still Not WorkingJesse12 Jun
  • Re: Function Still Not WorkingMartijn Tonies12 Jun
    • RE: Function Still Not WorkingTodd M. Boyd12 Jun
  • Re: Function Still Not WorkingSebastian Mendel12 Jun
  • Re: Function Still Not WorkingJesse12 Jun
  • Re: Function Still Not WorkingJesse12 Jun
    • RE: Function Still Not WorkingTodd M. Boyd13 Jun
  • Re: Function Still Not WorkingJesse13 Jun
  • Re: Function Still Not WorkingJesse15 Jun