List:General Discussion« Previous MessageNext Message »
From:Dave Sampson Date:February 10 2008 2:09pm
Subject:MYSQL db no-no: deleted root permissions (smile)
View as plain text  
Hey folks,

As with many lessons in linux world it takes a big oop for a big lesson.

system:
gentoo OS
webmin/virtualmin frontend


I was trying to apply permissions to usetrs so they can only access
certain DB's. This involved removing the associated user permissions
from the permissions list and creating seprate DB permissions.  This
worked great untill I messed with root and my non-root universal access
users.

I tried using other higher level permissions users but was always
blocked from the mysql DB. I guess this is where permissions info is
stored?

I "unmerged" mysql and re-"merged" mysql (package uninstall/install on
gentoo), then it asked my to initiate the new install.  It screamed at
the existance of a prevous mysql DB. So I thought it would be great to
keep all DB's and restart the MYSQL DB. so i deleted and re-initiated
mysql DB

still no glorry.

So how can I get  root user permission back into MYSQL?

Cheers

Thread
MYSQL db no-no: deleted root permissions (smile)Dave Sampson10 Feb