List:General Discussion« Previous MessageNext Message »
From:Chris Faust Date:July 4 2007 3:55pm
Subject:Cannot Connect: Can't create a new thread (errno 11)
View as plain text  


I'm wondering is someone could help us in trying to resolve the above error,
we have read through what threads we could find and tried all the
suggestions, but have had no luck.


There are no memory problems, in fact when this happens if there is still a
localhost client connection to the server you can do whatever you want,
everything is running normal. It just refuses all new connections. When it
happens there is plenty of memory on the machine and no load at all
(everything is running just as it should). Once things fall below 90,
everything comes back.


The problem happens when the process list hits the 91st process every time.
90 processes, no problems, the 91st process/connection gets the above error
and any after that simple gets "Can't connect to MySQL server".


We've tried all the obvious things, messing with the number of connections,
open files etc. Nothing seems to work.


We are running MySQL 5 on Centos 5 (flavor of RedHat). The machine is
dedicated to MySQL.


Below is a link to a text file that shows the OS limits for the mysql
account on the machine and the output from show variables (including it made
the message to large for the list).


If anyone has any suggestions, it would be appreciated.




Cannot Connect: Can't create a new thread (errno 11)Chris Faust4 Jul
  • Re: Cannot Connect: Can't create a new thread (errno 11)Alex Arul Lurthu5 Jul
  • RE: Cannot Connect: Can't create a new thread (errno 11)cfaust-dougot5 Jul