List:General Discussion« Previous MessageNext Message »
From:Jerry Preeper Date:December 8 1999 6:49pm
Subject:parse error - message repeated 140,000 times, please help
View as plain text  
I have a perl program that uses the (I know I need to update to
use DBI), and everything was running fine until I just recently had to
upgrade the DBD module from 0.93 to the current release for another
database program that I installed.  The program I have the problem with is
a news story database.  I have yet to be able to find out exactly what is
causing this.  Since I upgraded DBD, I now get the following error message
in my logs with about 140,000 consecutive entries each time it happens.
Yes, 140,000 lines of error messages each time it happens.  Needless to
say, it's eating up my hard drive pretty quickly....  I had to turn mysql
logging off, because the files just grew too large....  I'm running
3.22.14b-gamma on FreeBSD2.2.8 in case that matters.  I even turned off the
-w flag on the program and that doesn't stop it.  Which makes we wonder if
it's even that program that's causing the error.

DBD::mysql::st execute failed: parse error near ''8954643' at line 1 at
/usr/local/lib/perl5/site_perl/ line 172.

When the error happens, the number above in the parse error near gets
repeated a whole bunch of times, then it changes to another number which
gets repeated, and so on and so on...  The numbers don't seem to have any
rhyme or reason.  I've never seen anything like this.

I have tried submitting test stories into the database, which is where I
thought the error was based upon the frequency of the errors appearing, and
the error doesn't repeat when I try it.

I'm trying to locate in the access log what might have caused it, but this
error message doesn't give a PID or time, so that's proving to be a bit
difficult... It isn't preceded by another error message that is consistent.
 It doesn't appear to be someone submitting binary data, because it always
appears to be numbers only.  

The line referred to is:
    my $result = $sth->execute();
in the sub query

I have been trying to search the listquest archive, but I get javascript
errors using Netscape which seems to drop the list name from the search
query (NN3) with something about removespaces is not defined and in IE3 I
get a premature end of script headers internal server error... So much for
backwards compatability... (I'll email them later)  When I finally got on
their I could only find 3 threads about this type of error, one dealt with
inserting binary data (which I don't think applies here), one dealt with
incorrect code on inserting an email address (also doesn't seem to apply
here) and the final one had to deal with a regular expression
incompatability between versions. 

I'm really at a loss here and was wondering if anyone else may have run
across anything similar to this that might be able to point me in the right
direction to get this problem identified and solved... 


parse error - message repeated 140,000 times, please helpJerry Preeper8 Dec
Re: parse error - message repeated 140,000 times, please helpRuss Southern9 Dec
  • Re: parse error - message repeated 140,000 times, please helpJerry Preeper9 Dec