List:General Discussion« Previous MessageNext Message »
From:Denise Lopez Date:March 20 2007 10:07pm
Subject:Database creation question
View as plain text  
Hello everyone,

I had a really weird thing happen and I was wondering if anyone has seen
anything like this. From a shell command line I connected to a running
instance of mysql with the mysql -u root -p command. I successfully get
to a mysql prompt. I needed to create a new database and user for the
mysql > create database 'database name';
mysql > grant all privileges on 'database_name'.* to username@localhost
identified by 'password'; 

These 2 commands finished successfully and when I run the show databases
command, my new database shows up.  I can exit back to shell prompt and
reconnect to mysql with the command above and it still displays the new

Up to here is what I expected, here's the weird part.  With the username
and password from above I tried to create a table in my database and
received this error:

Can't create/write to file
I google'd this and the only suggestion was the disk that mysql was
trying to write to was out of space.  So I checked the space on
/usr/local/mysql/var and there is plenty of room on the drive.

Come to find out that the database directory didn't get created in the
data directory where all the database directories are located.

Any ideas why the mysql process didn't create the database directory?  I
already checked permissions on the /usr/local/mysql root mysql 755 and
/usr/local/mysql/var mysql mysql 700.

Thanks in advance.

Denise Lopez
UCLA Center for Digital Humanities
Network Services
Systems Engineer
337 Charles E. Young Drive East
PPB 1020
Los Angeles, CA 90095

Database creation questionDenise Lopez20 Mar
  • Re: Database creation questionJuan Eduardo Moreno20 Mar
    • RE: Database creation questionDenise Lopez21 Mar
      • Re: Database creation questionJuan Eduardo Moreno21 Mar
      • Re: Database creation questionBrent Baisley21 Mar
        • RE: Database creation questionDenise Lopez22 Mar