List:General Discussion« Previous MessageNext Message »
From:Jerry Preeper Date:December 1 1999 9:59pm
Subject:Re: Commands out of sync error
View as plain text  
I didn't get any replies but I did find my problem and fix.  Turns out I
was running a DBI/DBD module that was a little old.  As soon as I updated
them, everything seems to have worked like a charm.

>I'm trying to get a program installed and running into a glitch that I
>haven't seen before - there is a section of the code in the setup program
>that creates all the tables in the database.  The problem is, when I run
>the code the first table gets created and the then all the others fail.
>The error I get is  Creating table Category ... failed (DBSQL (19423):
>Fatal Error: Unable to execute query: (and then the sql command which is
>valid because I can paste it into the command monitor and then) Reason:
>Commands out of sync;  You can't run this command now at ./setup.cgi line 290
>I sort of understand the error from searching the listquest archive, but I
>don't know how to fix it. I didn't write the program and I'm more of a
>script-hack than a programmer :)  I guess somehow I need to fetch the
>results of each query in the foreach loop or something in the if statement
>for the category table.  The relevant code from the program follows.  If
>anyone can help, I would be most appreciative.

Commands out of sync errorJerry Preeper30 Nov
  • Re: Commands out of sync errorJerry Preeper2 Dec