List:General Discussion« Previous MessageNext Message »
From:TheRefUmp Date:June 30 2005 8:17pm
Subject:Found Wrong Record xxx (using 5.0.6 windoz)
View as plain text  
I will give the output below. I just ran an insert of a small amount of data into
Windoz/MySQL 5.0.6. Then, I ran a "myisampack" agains it. Finally, I ran  a myisamchk
against it and keep coming up against this error:
Found wrong record at 687081

Now, I'm the only one who has access to this database. What's is going on? Can anyone help
Enclosed is the output of each step below.


E:\MySQLData\5.0.6\sdidw>myisampack -v --tmpdir=e:\workdir table.MYI
Compressing table.MYD: (100349 records)
- Calculating statistics

normal:      9  empty-space:       0  empty-zero:         1  empty-fill:   9
pre-space:   0  end-space:         0  intervall-fields:   4  zero:        14
Original trees:  55  After join: 32
- Compressing file
Min record length:     39   Max length:     58   Mean total length:     46
Remember to run myisamchk -rq on compressed tables

E:\MySQLData\5.0.6\sdidw>myisamchk --tmpdir=e:\workdir -rqp --sort-index --analyze
- check record delete-chain
- parallel recovering (with sort) MyISAM-table 'mytable.MYI'
Data records: 100349
- Fixing index 1
- Fixing index 2
- Fixing index 3
- Fixing index 4
- Fixing index 5
- Fixing index 6
- Fixing index 7
- Fixing index 8
- Fixing index 9
- Fixing index 10
- Fixing index 11
Found wrong record at 687081


Switch to Netscape Internet Service.
As low as $9.95 a month -- Sign up today at

Netscape. Just the Net You Need.

New! Netscape Toolbar for Internet Explorer
Search from anywhere on the Web and block those annoying pop-ups.
Download now at
Found Wrong Record xxx (using 5.0.6 windoz)TheRefUmp30 Jun
  • Re: Found Wrong Record xxx (using 5.0.6 windoz)Gleb Paharenko1 Jul