List:General Discussion« Previous MessageNext Message »
From:Bruce Dembecki Date:June 18 2005 1:26am
Subject:5.0.7 Upgrade (from 4.1) on OS X doesn't recognize datadir
View as plain text  
So I am attempting a 5.0 upgrade from 4.1 on one of our OS X servers...

When attempting to launch mysqld it quits, with this error (showing  
two from the log files, happens with our build or the MySQL binary):

050617 14:03:46  mysqld started
line 2: --datadir=/mysqldata2: No such file or directory
050617 14:03:46  mysqld ended

050617 14:07:58  mysqld started
mysqld_safe64: line 2: --datadir=/mysqldata2: No such file or directory
050617 14:07:58  mysqld ended

Needless to say /mysqldata2 is present and accounted for, and has the  
correct permissions for mysql to be able to read/write data... It is  
a symlink to another volume, but if I substitute the true path to the  
volume, I get the same error...

I had problems with one version of 4.1 having problems figuring out  
where to write the log files and it turned out to be an absolute file  
name issue... eg it treated /logs/binlogs as being relative to the  
data directory, and not an absolute directory... I resolved that by  
changing the log file setting to read ../logs/binlogs and it worked  
fine. Assuming there was a similar problem here I have tried various  
levels of ../../mysqldata2 to make sure I am escaping from whatever  
directory it is starting me in, and have failed to get there, after  
switching up 7 levels, far more than would be needed to get back to  
root from anywhere in /usr/local/mysql-any-version

Any idea how I can get MySQL 5.0 to launch here would be greatly  
appreciated :-)

Best Regards, Bruce
5.0.7 Upgrade (from 4.1) on OS X doesn't recognize datadirBruce Dembecki18 Jun