MySQL Lists are EOL. Please join:

List:General Discussion« Previous MessageNext Message »
From:Michael Stassen Date:February 16 2005 5:57pm
Subject:Re: Table crash questions...
View as plain text  
Dan Tappin wrote:

> I have MySQL 4.1.8 installed on OS X 10.3.8 Server and I was in the 
> process of building a PHP / MySQL website.  After numerous connection 
> issues with the MySQL server I decided to take a look at the status of 
> my tables to check for corruption.
> 
> After running myisamchk I managed to loose all my data records for one 
> table.  Not a big deal As I was just in a testing phase an planned to 
> purge the data any way.  The problem is now when I run myisamchk on this 
> table I get:
> 
> Warning: table file /pathtomydatafolder/users.MYI was created in MySQL 
> 4.1+, use REPAIR TABLE ... USE_FRM to recreate it as a valid MySQL 4.0 
> table
> - recovering (with keycache) MyISAM-table 'users.MYI'
> Data records: 0

You have installed mysql 4.1.8, but this error message appears to come from 
mysql 4.0.x.  Any possibility you started the wrong server?  Which leads me 
to wonder which version of myisamchk you ran.  A PATH problem, perhaps?

> I tried "REPAIR TABLE users USE_FRM" with no help in resolving this 
> message.
> 
> Is this anything to even worry about??
> 
> Dan T

Michael
Thread
Table crash questions...Dan Tappin16 Feb
  • Re: Table crash questions...Michael Stassen16 Feb
    • Re: Table crash questions...Dan Tappin16 Feb