MySQL Lists are EOL. Please join:

List:General Discussion« Previous MessageNext Message »
From:N S Date:February 16 2005 3:28pm
Subject:Problem with the stopword file in 4.1.9-Max
View as plain text  
Hi

I set ft_min_len_word = 3 and ft_stopword_file =
/etc/stopword.cnf in my.cnf file under the [mysqld]
section

I then restart the server and rebuild the indexes with
REPAIR TABLE ... QUICK

The ft_min_len_word=3 seems to work: I get the
expected results when quering for 3-letter words

Unfortunately, that is not the same with the stopwords
The default character set of the server is utf8. All
data in the tables are utf8 as well. So, I thought
that the stopword file should be in utf8 as well. If
that is wrong please say so. Now the syntax of that
file: I've tried one word each row, I've tried
double-quotes around words, I've tried comma-separated
as well as double-quotes and commas together, also
tried space-separated. I've tried anything I could
think of. None of those seem to work. When I query for
 one of those stopwords, I get results :(

After each change to the stopword file, I always
restart server, rebuild indexes etc.

I've run out of ideas. Any help would be appreciated.
Thx in advance, Nick
    


		
__________________________________ 
Do you Yahoo!? 
Yahoo! Mail - 250MB free storage. Do more. Manage less. 
http://info.mail.yahoo.com/mail_250
Thread
Problem with the stopword file in 4.1.9-MaxN S16 Feb
  • Re: Problem with the stopword file in 4.1.9-MaxGleb Paharenko21 Feb