List:General Discussion« Previous MessageNext Message »
From:Rolando Berrios Date:January 1 1970 12:00am
Subject:mod_auth_mysql 2.20 / apache_1.3.X / RedHat Linux 5.2 problem
View as plain text  
Hey all,

I've been trying to install mod_auth_mysql 2.20 on my RedHat Linux 5.2
machine to work with either apache 1.3.3 or 1.3.6(latest) for the last
few days now and haven't been able to get apache running successfully.  My
C knowledge is pretty much non-existent, so I'm not sure what exactly I'm
missing from the error messages that I'm getting.

I manage to get as far as compiling mod_auth_mysql with these
configuration options:

./configure --with-apache=/usr/local/apache_1.3.3 

and apache with these (after modifying the mod_auth_mysql.c file in
src/modules/auth_mysql so that the paths to the includes
auth_mysql_config.h and mysql.h are recognized):

./configure --enable-module=most --enable-shared=max 

I've even tried to modify the Configuration files in apache_1.3.X/src/ so
that the extra FLAGS are included, but the CFLAG in Configuration.apaci
gets overwritten and when I look at the FLAG src which is $(SRCDIR)/apaci,
I don't find anything that looks like the CFLAG I've modified.  I'm not
sure if I even need to be doing this.

When I try to execute httpd, this is my result when I try to use

[root@example apache_1.3.3]# /usr/local/apache/sbin/httpd start
Syntax error on line 56 of /usr/local/apache/etc/httpd.conf:
Cannot load /usr/local/apache/libexec/ into server: 
/usr/local/apache/libexec/ undefined symbol: 

I'm totally lost at this point and don't know what else to do.  I've
tried looking at the mailing list archives and I haven't been able to
find anything useful, except the knowledge that other people have gone
through this before, but no answers.

Any help whatsoever would be greatly appreciated!

mod_auth_mysql 2.20 / apache_1.3.X / RedHat Linux 5.2 problemRolando Berrios13 Apr
  • Re: mod_auth_mysql 2.20 / apache_1.3.X / RedHat Linux 5.2 problemHarry Brueckner13 Apr
    • Re: mod_auth_mysql 2.20 / apache_1.3.X / RedHat Linux 5.2 problemRolando Berrios14 Apr
      • Re: mod_auth_mysql 2.20 / apache_1.3.X / RedHat Linux 5.2 problemVivek Khera14 Apr