MySQL Lists are EOL. Please join:

List:General Discussion« Previous MessageNext Message »
From:P.V.Anthony Date:November 9 2004 12:41pm
Subject:Re: connection problem with 4.1.7
View as plain text  
P.V.Anthony wrote:
> Hi,
> 
> I am having an intermitten connection problem with MySQL 4.1.7 .
> 
> Here is the setup.
> 
> Intel P4 with HT
> Fedora Core 1 kernel 2.4.27 smp
> MySQL version 4.1.7 (RPM install from mysql.org)
> Qmail with vpopmail using mysql (www.qmailtoaster.com)
> 
> Sometimes I cannot login to qmail to check mail. Using thunderbird or 
> even webmail.
> 
> Only way to solve the problem is to restart MySQL. Then everything is 
> ok. After maybe 2 hours the same problem again.
> 
> I am concluding that this is a MySQL problem because other apps that use 
>  MySQL also shows problems.
> 
> qmail vpopmail is using socket and my cms (WebGUI) is using tcp to connect.
> 
> I have tried to check the logs at /var/lib/mysql. But do not see 
> anything any error. I do see a warning like this,
> 041106  9:50:59 [Warning] Asked for 196608 thread stack, but got 126976
> 
> The strange thing is that I can still connect to MySQL using webmin.
> 
> Is there any other thing I can do to find out what is causing the 
> problem? Maybe I have made some silly mistake.
> 
> Please advice and help.
> 
> P.V.Anthony
> 

Problem solved.

As usually it was my mistake.

In the content management system that I used, I set the connection to 
the database to be presistent or pooling. Something like that.

Once I set it back to normal, that is not to have persistent 
connections, all was solved.

It seems that there was too many connections and it just did not allow 
any more connections.

Sorry to have troubled everyone. It was my mistake. It was warned in the 
documentation in the CMS.

I found the problem by using the following command.

# mysqladmin -u root -ppassword processlist

Thanks to everyone who helped.

P.V.Anthony
Thread
connection problem with 4.1.7P.V.Anthony6 Nov
  • Re: connection problem with 4.1.7P.V.Anthony9 Nov
AW: connection problem with 4.1.7Kostas Pyliouras6 Nov
  • Re: AW: connection problem with 4.1.7P.V.Anthony6 Nov