MySQL Lists are EOL. Please join:

List:General Discussion« Previous MessageNext Message »
From:P.V.Anthony Date:November 6 2004 5:00pm
Subject:Re: AW: connection problem with 4.1.7
View as plain text  
> 
> Hi,
> 
> I am having an intermitten connection problem with MySQL 4.1.7 .
> 
> Here is the setup.
> 
> Intel P4 with HT
> Fedora Core 1 kernel 2.4.27 smp
> MySQL version 4.1.7 (RPM install from mysql.org)
> Qmail with vpopmail using mysql (www.qmailtoaster.com)
> 
> Sometimes I cannot login to qmail to check mail. Using thunderbird or 
> even webmail.
> 
> Only way to solve the problem is to restart MySQL. Then everything is 
> ok. After maybe 2 hours the same problem again.
> 
> I am concluding that this is a MySQL problem because other apps that use 
>   MySQL also shows problems.
> 
> qmail vpopmail is using socket and my cms (WebGUI) is using tcp to connect.
> 
> I have tried to check the logs at /var/lib/mysql. But do not see 
> anything any error. I do see a warning like this,
> 041106  9:50:59 [Warning] Asked for 196608 thread stack, but got 126976
> 
> The strange thing is that I can still connect to MySQL using webmin.
> 
> Is there any other thing I can do to find out what is causing the 
> problem? Maybe I have made some silly mistake.
> 
> Please advice and help.
> 
> P.V.Anthony

Kostas Pyliouras wrote:
 > Hi,
 >
 > When you have this problem, do the MySQL client applications work? 
Have you tried logging in with the mysql client?
 >
 > Kostas
 >

Thank you very very very much for replying.

Yes, I can login with mysql client. I can even login using webmmin.

Here is another strange thing. Once I have logged in using mysql client 
then everything works again. I do not have to restart MySQL. This is 
very very strange. What could be the problem?

There is no error in the error log file.

Is there any other place I have to look at?

Please do continue to help.

P.V.Anthony


Thread
connection problem with 4.1.7P.V.Anthony6 Nov
  • Re: connection problem with 4.1.7P.V.Anthony9 Nov
AW: connection problem with 4.1.7Kostas Pyliouras6 Nov
  • Re: AW: connection problem with 4.1.7P.V.Anthony6 Nov