List:General Discussion« Previous MessageNext Message »
From:Egor Egorov Date:July 26 2004 3:48pm
Subject:Re: after upgrade unicode characters changed to question marks
View as plain text  
"Stefan Klopp" <stefan@stripped> wrote:

> We recently upgraded our mysql server from 3.23 to 4.0.18 and have found
> that all of our Unicode characters are now being displayed as question marks
> (?). Anyway this only happens when viewing over the web as when we view via
> the shell mysql we can see the characters fine. 

Not a MySQL issue: both versions 3 & 4 don't manage unicode characters. Only
4.1 does. MySQL 3 & 4 just store the binary data. 

Try to debug your web software and first recompile it with .so.12 client libraries
(the ones that comes with MySQL 4.0).






-- 
For technical support contracts, goto https://order.mysql.com/?ref=ensita
This email is sponsored by Ensita.net http://www.ensita.net/
   __  ___     ___ ____  __
  /  |/  /_ __/ __/ __ \/ /    Egor Egorov
 / /|_/ / // /\ \/ /_/ / /__   Egor.Egorov@stripped
/_/  /_/\_, /___/\___\_\___/   MySQL AB / Ensita.net
       <___/   www.mysql.com



Thread
after upgrade unicode characters changed to question marksStefan Klopp21 Jul
  • Re: after upgrade unicode characters changed to question marksJean-Marc PULVAR22 Jul
  • Re: after upgrade unicode characters changed to question marksStefan Klopp22 Jul
  • Re: after upgrade unicode characters changed to question marksStefan Klopp22 Jul
  • Re: after upgrade unicode characters changed to question marksEgor Egorov26 Jul