List:General Discussion« Previous MessageNext Message »
From:Michael Widenius Date:April 10 1999 10:54am
Subject:mysql 3.22.20a/IRIX 6.5 DSO problems
View as plain text  
>>>>> "Jim" == Jim Lawson <jtlawson+bulk@stripped> writes:

Jim> Hi,
Jim> We recently upgraded to mysql 3.22.20a (from 3.22.13) and we are starting
Jim> to have dynamic library problems.

Jim> The symlink seems to point to the current version of
Jim> the shared library.  However, old binaries linked against mysqlclient
Jim> complain loudly when we try to run them:

Jim> For example, apache-1.3.4 / PHP 3.0.7 with mysql reports:

Jim> Cannot load /local/apache-1.3.4-19990301/libexec/ into server:
> 140175:/local/apache-1.3.4-19990301/bin/httpd: rld: Fatal Error: Cannot find object
> with version 5.0

Jim> If we remove the symbolic link, or point it to an older version, Apache/PHP
Jim> starts but then the mysql client itself reports:

Jim> 131666:mysql: rld: Warning: Version Search Suppressed Because Object
> in liblist has non-sgi interface version (6.0)
Jim> 131666:mysql: rld: Fatal Error: Cannot Successfully Map soname ''
> under any of the filenames
> /local/lib/mysql/

Jim> It seems that the IRIX runtime linker has a problem with the major version #
Jim> of libmysqlclient (6.0).  

Jim> I've tried relinking the clients with the new shared library, and they all 
Jim> work, save the most important client - Apache/PHP/MySQL, which segfaults
Jim> when I try to start the server with linked against the new 
Jim> library.

Jim> Anyone else running the latest MySQL under IRIX 6.5?


One solution is to link PHP staticly with MySQL.  Have you tried this.

Can you get a gdb backtrace of this?

Please check that you are compiling with the right MySQL include
files;  If not you will get core dumps!


mysql 3.22.20a/IRIX 6.5 DSO problemsJim Lawson6 Apr
  • mysql 3.22.20a/IRIX 6.5 DSO problemsMichael Widenius10 Apr